
Kudo Catalog Reader for Windows

This User guide is text only.  To view the Kudo User Guide with graphics and text open the 

file "User Guide Catalog" in the Read Me folder.

Welcome to Kudo Catalog Reader for Windows, a fast and easy way to find, use and view digital

images, sounds, or movies.  The Kudo Catalog Reader opens and reads Kudo Catalogs.  A Kudo 

Catalog is made with the Kudo Cataloger for Windows and contains records of media files.  Each

record is made up of a thumbnail size image and associated text fields which describe the media 

file. Think of each thumbnail as a miniature representation of your original image, except that it 

takes up very little memory and its formatted for easy distribution.  Kudo Catalogs are 

distributed on CD-ROMs, Syquest drives (or other removable media), networks and the Internet 

(or other on-line services).  A Kudo Catalog can contain thousands of records of media files.  

The Kudo Catalog Reader has the following features and functions:

• Invoke media players to display or listen to a media file.

• Reference the media file's location, size, type, and creation date.

• Display original full-sized images in a floating window.

• Place a media file into a graphics or multimedia document via Drag and Drop.

• Open a media file with its associated application.

• A single Kudo Catalog can contain 64,000 records of media files.

• Extend the functionality of the Windows Catalog Reader via OLE.

The Kudo Catalog Reader Window



Installing Kudo Catalog Reader for Windows

To load and run Kudo Catalog Reader for Windows, you need a computer running MS-Windows 

3.1, WFW 3.11, NT 3.51 or Windows 95. 

Note: This Guide assumes you have a basic working knowledge of MS-Windows. For 

background information on Windows, please refer to the Windows documentation that 

came with your system.

This section will enable you to install Kudo and become familiar with its most important features

in a few short minutes.

1. Kudo Catalog Reader is the distributable form of Kudo.  You can get it from a CD-ROM, 

the Imspace Systems Web Site http://www.imspace.com, or from your network. To install

Kudo Catalog Reader, double click on the winstall.exe file from the File 

Manager/Explorer or select the [Run] command from the File menu in the Windows Program

Manager. Then type the volume drive letter (of the CD-ROM, network volume, etc.) 

followed by a colon, a backslash and winstall.exe. For example, if this is a CD-ROM, and

the drive letter is D, you would type: D:\winstall.exe.

If the winstall.exe is located on a network volume or Internet site, you may need to consult with 

your system administrator for access rights and/or assistance.

2. The winstall.exe installer program will ask if you would like to install Kudo Catalog 

Reader onto your hard drive or leave it on the CDROM. If you choose to place the 

program on your hard drive, it will occupy approximately 2.6 MB of disk space. If you 

choose not to place the program onto your hard drive, Kudo will still need to place a few 



image filters and DLL system files into your Windows directory. These files give Kudo the 

ability to work with your media files and applications.

Launch the Catalog Reader by double-clicking on the Catalog Reader icon. From the File

menu, select [Open]. You will be presented with a dialog box. Most CDROMs created 

with Kudo will have the Kudo catalogs in the WIN_KUDO directory. Choose one of these and

click OK. You can also launch Catalog Reader by double-clicking on a catalog icon.

3. You should now see a Kudo catalog. Click on a thumbnail to select it. Pull down the 

Image menu and select Display Original to see the image in a full-sized window. Close this 

window.

4. To launch the associated application, double click on a thumbnail. If an image filename 

extension is associated with an application, the application will launch and load the image

file.

5. Next, click on the List View button. The list view presents records and file notes in a 

column.

6. Click the Find button to open the Find Image dialog box. This will allow you to locate 

records within the catalog that have specific characteristics. Click on the arrow in the first

combo box (characteristic to search) to reveal its choices. Select [Name] to tell Kudo to 

search on filename. Click on the arrow in the combo box to the right (search operators) 

and select [contains]. Enter part of a file name in the right-most combo box. Click the [Find] 

button to search the catalog for all records that meet the specified characteristic. Kudo 

will then display only those records. Click the [Find] button again and select  Everything 

to find and display all records in the catalog.



7. Position the mouse cursor over the Riffle control (the double-headed arrow with tick 

marks) in the lower right hand corner of the Catalog Reader window. Click and hold the 

mouse button down over the Riffle control to zip through the contents of the catalog. 

Using the Riffle control is like pressing Play and Fast Forward or Reverse on a VCR to quickly 

move forward or backward while watching the frames flash by. Experiment with this 

feature and refer to the section on the Riffle Feature later in this guide for further details.

8. Finally, if you are using Aldus PageMaker, QuarkXPress or another supported 

application, open a document in that application and position its window so that it will be 

visible behind the Kudo catalog window. Return to Kudo, select a record and drag it into the 

document window. Kudo will find the original image file and place it in that document.

These are some of the many features of Kudo Catalog Reader. Try the different menu commands 

and discover additional features. The following sections of this User's Guide provide more detail 

on all features and on managing Kudo catalogs.

Opening a Catalog

1. You can open a Kudo Catalog by dragging a file with the KDB extension from the File 

Manager/Explorer into the open Kudo Catalog Reader Window.  

2. You can open a Kudo Catalog by double clicking on the KDB file in the File 

Manager/Explorer window.  

3. You can open a Kudo Catalog by double clicking on a catalog icon from the Program 

Manager Program Group or Windows 95 Desktop folder.

4. You can open a Kudo Catalog from the Kudo Catalog Reader from the File Open menu. 



In the File Name text box, type the path/filename of the catalog you want to open or 

choose the filename using standard Windows selection methods. Click OK. The selected 

catalog window opens, displaying its records. The Open dialog appears.

To open several catalogs, repeat the above steps for each catalog you want to open. Each catalog 

you open will appear in its own window. Use the Window menu selection to Tile or Cascade 

multiple open catalog windows. Clicking in a catalog window makes that window active; any 

menu commands or actions you perform affect only the active window.

Kudo displays several thumbnail images in the window. At a glance, Kudo shows you what the 

image looks like, its size, and its filename.

View buttons
The Gallery View, small Gallery View and List View buttons allow you to toggle between views.

Switch between the views by clicking the view button you prefer.

• The small gallery view uses a grid style layout and allows you to view many images, but 

with no file information available. You can select an image, and click the [info] button 

to read more information.

• The gallery view is the standard view, like the small gallery view, except that it shows 

larger thumbnails, and file information. Fewer thumbnails can be fit onto a screen in 

gallery view. Click the Info button to view detail about the selected record.

• The list view uses a vertical layout with fewer thumbnails in the window but with the 

notes field to the side so you can view the image and the notes at the same time. 



Find button
Use the Find button ( under the menu bar ) to search the catalog for records of media files with 

specific characteristics. Kudo searches the catalog and displays the records that were identified in

the search. All other records are hidden from view. 

For example, if you search the catalog's notes for a client name, Kudo Catalog Reader only 

displays the records it found with that client name. Kudo does not delete or edit the remaining 

records; it just hides them from view. To view all the records in the catalog, use Find to search 

the catalog for [Everything] or select Find-All from the Image pull-down menu. When you select

the Find feature, Kudo displays a dialog.

Use the first combo box to tell Kudo the record data field it should search. You can search by 

name, size, date modified, notes or location.

Use the next combo box menu to tell Kudo how to search the catalog. The selections in this 

combo box will become available after you make a selection in the first combo box.

• Use the edit text box to tell Kudo what words or information to search for. Wild card 

characters such as * or ? are not necessary.

• You can also choose the Find option using the Image menu.

For example, you may have a catalog that includes a series of aircraft clip art images. You can 

use the Find button to search the catalog for any thumbnail records whose notes contain the word

[Plane]. To return to the full catalog, use Find and choose [Everything] or select Find-All from 

the Image pull-down menu.



Info button
The Info button ( under the menu bar ) gives you quick access to a record's information. This 

option tells you the file kind, volume, size and any notes you have added to the record.

The Info Window.

• Select a record

• Click the Info button.

• Kudo will display the information in a floating window. 

• You can also choose Get Info using the [Image] pull down menu.

When the Info window is open, click on other records to display their information.

Using the Riffle Feature
Kudo's main window displays the records in a gallery or list format. When using the Riffle 

feature to zip through the catalog, it displays the images one at a time in the lower right corner of

the main window. 

To zoom through your catalog:

• Click and hold on the Riffle control. 

• Kudo will fly through the catalog. You will see one thumbnail after another in the lower 

right corner just above the Riffle control. 

• Release the Riffle control when you see the record you want. 

• When you release the control, Kudo will show the records that surround the one you 



chose. 

• Kudo stops near the record that you choose. Your reactions may be slower than Kudo's 

Riffle feature, so when you release the Riffle control, you will select a record that is a few

frames ahead of the one you wanted. Kudo scrolls the catalog to the appropriate location 

and displays the surrounding records.

Kudo will advance through the catalog until you release the control or until it reaches the end of 

the catalog. With the Riffle feature, you can zoom forward to the end of the catalog or you can 

zoom backward to the beginning.  Control the Riffle speed and direction by dragging the mouse 

to the left or right while holding it on the Riffle shuttle control. 

• Drag the mouse to the right or left to control the speed and direction. 

• Drag the mouse to the right to increase the speed. Drag the mouse to the middle and 

Kudo will stop riffling. When you drag further to the left, Kudo will start moving in the 

opposite direction and increase speed. 

• You will find the center point of zero speed. At this point, Kudo stops moving and holds 

on one record.

The further from the center, the faster the Riffle scrolls.

Display Original
Kudo maintains a link between the record image in the catalog and the original file. While in 

Kudo, use the Display Original ( or CTRL-E ) to preview the original image file in a full-sized 

window. 

• Select the record of the image that you wish to view



• Choose Display Original from the Image menu.

• Kudo will find the original image file and display it in a full-sized window.

To preview other image files, simply click their records while the Preview window is open. 

Note: Kudo can not preview files stored on off-line disks (i.e. floppy disks, removable 

cartridges, etc.). If the file is on an off-line disk, Kudo will ask you to insert the correct 

disk. 

Get Info
Same as the Info Button. 

Find
Same as the Find Button.

Find All
Finds all the objects in the catalog.  You can use CTRL-A to quickly locate all records.  Please 

refer to the Find Button section.

Image Placement into applications.
There are four methods for placing an image from a Kudo catalog into a document:

• Drag and Drop.

• Copy and Paste.

• You can also note the file name and location and use it to insert the image from 

within the target application "by location".



• Launch an associated application.

Kudo takes advantage of Windows technology (DDE and OLE2.0) which allows you to Drag 

and Drop images onto all popular graphics applications. When you Drag and Drop to selected 

desktop publishing and other page layout applications, Kudo places the image with pinpoint 

accuracy. Use Drag and Drop to save time. This single step operation takes less time than 

manually placing images into a document. 

Note: Pinpoint accuracy requires an OLE2.0 client application or a special Kudo Place 

Module. Place Modules are included for MS Word, PageMaker, QuarkXPress.  With 

QuarkXPress, you will need to copy the M_QUARK.XXT from the Kudo directory to the 

directory where QuarkXPress is installed.

Drag and Drop
With Drag and Drop, simply drag the record from your catalog to an open document. Kudo will 

find the original image file and place it in the document.

• Select the record.

• Hold down the mouse and drag it to the open document.

NOTE: The format of the file being placed must be supported by that application.

For Microsoft Word ( and other word processors ) When the image is dropped, it will be 

inserted at the exact location of the Word I-beam (insertion point).

When you drag a record over an application, you will see the cursor change shape; if it is a 



square, then you can drop the record.  If the cursor is a circle with a slash through it, you will not

be able to drop the record.

Release the mouse button and Kudo will find the image file and place it into the document.

Drag and Drop can be used from Kudo Catalog Reader onto the following applications:

• All graphics applications that support Drag and Drop from the File Manager. This 

includes virtually all leading applications.

• All graphics, desktop publishing, and multimedia applications that are OLE 2.0 clients. 

OLE2.0 clients provide pinpoint accuracy when dropping onto a page layout.

• In addition to the above, Kudo includes Place Modules for the following applications that

are not OLE 2.0 clients, but could benefit from Drag and Drop with pinpoint accuracy:

QuarkXPress version 3.12 and 3.3

Aldus PageMaker version 4.2 and 5.0

Microsoft Word version 2.0

Harvard Graphics version 2.0

Copy and Paste

You will be able to drag and drop images to all leading graphics applications. They all support 

Windows Drop-onto, and for pinpoint accuracy, many even offer OLE2.0 (client) support. For 

other applications and older Windows 2.x applications that do not have these capabilities, you 

can still place an image using copy and paste.

• Select the record image.

• Choose [Copy Thumbnail] under the Edit menu.

• Kudo will find the original image file and copy it to the clipboard.



• Open the target document.

• Choose [Paste] under the Edit menu of the target document.

Note: When you use copy, the entire original image file is placed on the clipboard. Be 

sure you have enough RAM to support this action.

By Location

Some applications do not support OLE 2.0 and nor do they support any easy method of image 

placement, but they do work with some graphics.  Each program has a special import command 

or feature that you need to invoke.  Each Kudo catalog contains a location field that tells you 

where this image came from.  If the original image is available, you can note its location and 

enter that into the import command of your target application.

Launch Associated Application

The Kudo Catalog Reader will launch an application associated with the record's file type when 

the thumbnail image representing the media file is double-clicked.  Create an association with 

the file type from the File Manager, or create a new file type under Windows 95, so that your 

preferred graphics program will launch when the thumbnail image is double-clicked.

When you open a catalog, Kudo lists the records according to when they were added to the 

cat§a log. Use the Sort menu to list the records by file size, date or even location. For example, ▯

sort by Modification Date to see which image files have been recently updated or sort by [Kind] 

to group images by file type.



Sort
Sort and Find use the same criteria but they affect the catalog differently. With Find you use the 

criteria to determine which records Kudo should display and which it should hide from view. 

With Sort, you re-arrange the records that are displayed.

When you close and re-open the catalog, Kudo shows all the records in their original order.

To sort your catalog:

• Select sorting criteria from the Sort menu.

• Kudo will automatically re-arrange the records and display them in their new order

Print

Use the standard Printer Setup and Print commands to print part or all of your catalog. The Print 

feature always prints the current selection of records. For example, to print all records in a 

catalog, use the Find command to find [everything] (the default), and then select print from the 

File menu. 

To print records with file name and size only, select Gallery View prior to printing your catalog. 

Printing a catalog in Gallery View prints the maximum number of records per page.. Printing a 

catalog in List View provides more text information on images but prints fewer records on each 

page.

NOTE:  To print the original image, you must place the image into a graphics 

application



Search Tips for All Our Yesterdays™

TIP  1:  To avoid delay, we recommend the use of the 72 dpi image files for quick preview.  Use 

of the 600 dpi images may result in system delay when placing them from the catalog.

TIP 2:  The notes accompanying each image are rich in keywords - objects are described in great

detail, many with historical references and cross-references. We have also included 

keywords that describe the image in emotional or esthetic terms.

TIP  3: Some of the images within a volume have been taken from one original plate that 

contained many images.  In such cases we have identified each image from that plate 

with a letter in parenthesis, e.g. (a).  If you would like to compile all the images from 

one plate, simply expand your search criteria  by choosing "notes" "contains" then type

in the letter in parenthesis, such as (a) or (c) or (f).  The browser will find all the 

images that were originally found all on that one plate.

TIP  4:  The Index Disc is capable of searching for images across all ten volumes.  If you wish to

preview the images on one particular volume on the  Index disc, first use the "Find" 

button or "Find " command in the "Image" menu.  In the first pull-down menu  choose 

"Notes", in the second pull-down menu choose "starts with" and then type in the name 

of the volume you wish to preview (e.g. Paintings & Engravings).  The browser will 

automatically go to the first image in that particular volume.  To expand your search 

for images of that description not in that volume, choose "notes" "contains" and the 

browser will search the entire library for images that fit that description.
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